Chat with us, powered by LiveChat

Nom de domaine - Hébergement - Messagerie

Accueil » Actualité » WordPress 5.0 et son nouvel éditeur Gutenberg

WordPress 5.0 et son nouvel éditeur Gutenberg

WordPress 5.0 est disponible depuis le 6 décembre 2018.

Cette nouvelle version de WordPress opère un changement MAJEUR : l’éditeur WYSIWYG auquel les utilisateurs de WordPress étaient habitués pour rédiger et éditer leurs contenus est remplacé par un nouvel éditeur par défaut « Gutenberg ».

Gutenberg apporte de nouvelles fonctionnalités avec une mise en page par « blocs » qui devrait permettre aux utilisateurs avancés de réaliser des mises en page personnalisées plus poussées.

Comme avant chaque mise à jour majeure de cette nature, il est conseillé de réaliser une sauvegarde des contenus de votre site, ainsi que de sa base de données. Cela vous permettra de réinstaller votre site à son état initial en cas de conflit.

A noter que vous n’êtes pas obligé de mettre à jour votre site vers cette dernière version de WordPress. Les mises à jour de sécurités continueront à s’appliquer si vous utilisez une version antérieure de WordPress. En revanche, il est possible que vos thèmes et plug-ins puissent ne plus fonctionner à plus ou moins long terme avec d’anciennes versions de WordPress.

Avant de mettre à jour votre installation de WordPress vers la version 5, il est conseillé :

  • Contactez l’éditeur du thème utilisé sur votre site pour vérifier sa compatibilité avec le nouvel éditeur Gutenberg.
  • Contactez les développeurs des plug-ins (extensions) utilisés sur votre site pour s’assurer qu’ils sont compatibles avec Gutenberg

En cas de doute ou si vous craignez une incompatibilité / conflit ou si vous avez déjà mis à jour WordPress et êtes confrontés à des problèmes d’édition, l’équipe WordPress met à disposition l’extension « Classic Editor  » . Classic Editor est un plug-in officiel de WordPress qui sera maintenu au moins jusqu’en 2022.

Cette extension permet de remplacer le nouvel éditeur « Gutenberg » par l’éditeur classique de WordPress auquel vous étiez habitué. Il permet même selon la configuration choisie après installation de basculer d’un éditeur à l’autre.